Думаете о переходе на российские средства защиты? Мы готовы помочь! Подробнее

База знаний

10483 - «Континент-АП». Ошибка 0x80090017

Продукт:  Континент 3

Версия: 3.7

Дата изменения: 28.09.2020

28 сентября 2020

Проблема

При импорте сертификата в «Континент-АП» или при попытке подключения возникает ошибка: "Ошибка работы с криптопровайдером 0x80090017. Тип поставщика не определен". Возможно, перед использованием «Континент-АП» на ПК была установлена система управления Континент, в составе которой есть криптопровайдер «Код Безопасности CSP».

Решение

Возможное решение проблемы – удалить «Континент-АП», очистить реестр от неиспользуемых данных (к примеру, программой CCleaner), повторно установить «Континент-АП». В ходе инсталляции будет восстановлен криптопровайдер, который вызывает ошибку.

Информация оказалась полезной?